[alsa-devel] ASoC: sh: fsi: Build proble in 3.4-rc4

kuninori.morimoto.gx at renesas.com kuninori.morimoto.gx at renesas.com
Mon Apr 23 01:58:53 CEST 2012

Hi Rafael

> There is a build problem in sound/soc/sh/fsi.c which seems to be fixed by
> the following patch.  I'm unsure if that is the right fix, though.

Thank you about this patch.
But this issue was solved by below patch on Mark's/for-3.4 branch

commit cdf27f373781d8740b874b0b5c18142df32ebb52
Author: Paul Mundt <lethal at linux-sh.org>
Date:   Tue Apr 17 19:13:04 2012 -0700

    ASoC: fsi: update for dmaengine prep_slave_sg fallout.
    Leading up to the ->device_prep_slave_sg change in
    185ecb5f4fd43911c35956d4cc7d94a1da30417f 'dmaengine: add context
    parameter to prep_slave_sg and prep_dma_cyclic' a generic wrapper was
    added in place to guard against the API change, though the fsi driver
    wasn't updated in the process (presumably its dmaengine support hadn't
    been merged yet at the time). This trivially switches over to the new
    wrapper and gets it building again.
    Signed-off-by: Paul Mundt <lethal at linux-sh.org>
    Acked-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
    Signed-off-by: Mark Brown <broonie at opensource.wolfsonmicro.com>

More information about the Alsa-devel mailing list