[alsa-devel] No sound on Quanta KN1 with kernel 3.4

Uros Vampl mobile.leecher at gmail.com
Wed Apr 18 19:33:35 CEST 2012

On 18.04.12 18:41, Takashi Iwai wrote:
> Ah, does it affect both?
> What happens if you change the pin 0x10?  Does it affect the headphone
> or speaker output?

Pin 0x0f affects both. Pin 0x10 affects neither.

> Does the headphone output work with 3.4 kernel at all?

No. I always tested both speakers and headphones with each patch (and 
without patches). There was never any sound from either of the two.

> Also, just to be sure, try the patch below in addition to another.
> This will disable the COEF setup, and it wasn't applied to previous
> models.

This patch does the trick! First I tried it with the patch that deletes 
two lines from hda_codec.c, worked already, but there was no Speaker 
control. Then I instead tried with the patch that sets pin 0x0f. Sound 
works and I have a Speaker control. Interesting thing though, the 
Headphone control does nothing and the Speaker control affects both 
speakers and headphones. Maybe pin 0x10 is bogus too.

Also interesting, the Auto-Mute control does nothing. No matter what 
it's set to, when I plug in headphones the speakers go silent. It seems 
the machine has hardware auto-mute handling.

Thank you for your work, I now have sound again!


More information about the Alsa-devel mailing list