[alsa-devel] VT1708 clicks & pops

Forest Bond forest at alittletooquiet.net
Tue Sep 20 01:14:13 CEST 2011


On Fri, Sep 16, 2011 at 04:36:01PM -0400, Forest Bond wrote:
> I have two boards with a VT1708:
> * VIA EPIA EX15000G
> * VIA VB8002
> I'm using VLC to play audio via PulseAudio to the analog outputs.  The VB8002
> sounds great, but the EX15000G has random pops and clicks in the output.  Both
> machines are running exactly the same configuration (they are using the same
> pre-built OS image).

Maybe this issue would be more approachable if I could produce it without
PulseAudio involved?

Incidentally, these boards both produce a crackling/static sound when PulseAudio
is playing and the PCM mixer is turned all the way down.  I have seen scattered
reports of this in various bug trackers.  The problem does not occur when
playing via alsa directly.  One thing I have noticed is that the crackling noise
follows the rhythm of the music being played.  It actually sounds like the music
has been heavily distorted (i.e. via extreme digital clipping) and then
attenuated significantly.

It seems likely that there are driver issues that PulseAudio is exposing.  What
can I do to track them down?

Forest Bond
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110919/eb5877ae/attachment.sig 

More information about the Alsa-devel mailing list