[alsa-devel] Creative X-Fi 51 Pro Support

Christian Hoff Christian_Hoff at gmx.net
Sat Oct 15 16:16:45 CEST 2011

Dear all,

I just bough and installed a new Creative X-Fi 51 Pro USB sound card. The card works, but it recognized as a full speed 1.1 device instead of high speed (usb 2.0). This causes some limitations - for example I cannot play  5.1ch 24bit/96000Hz audio streams, but only 5.1ch 16/44000Hz.

 There are various other reports of this behavior in the net(for example [1]), but so far nobody was able to come up with a solution.

I would like to fix this in ALSA - probably some kind of vendor-specific quirk is needed which tells the card that it can safely turn on its high-speed capabilities. My assumption is that Creative just disabled the USB high speed features by default because some other OS'es might have problems with audio class 1 devices running at high speed.

Now what I would need is some sort of technical input from Creative. A technical documentation of the card or some sample code would be nice. Maybe they are going to send me the specs for their X-Fi 51 Pro if I ask, but the problem is whom at Creative should I ask?

Or is there anyone who already has some technical docs for that card available? The reason why I ask is because e.g. the remote control quirks would have required some docs from Creative, so I assume Creative has been sending you technical input in the past.

Thank you very much for any help on that matter.


Christian Hoff

[1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/798795/comments/4
Empfehlen Sie GMX DSL Ihren Freunden und Bekannten und wir
belohnen Sie mit bis zu 50,- Euro! https://freundschaftswerbung.gmx.de

More information about the Alsa-devel mailing list