[alsa-devel] Kernel: snd-usb-audio: probe of 2-2:1.0 failed with error -5

Daniel Mack zonque at gmail.com
Tue Nov 29 18:20:35 CET 2011

On 11/29/2011 05:58 PM, Linus Torvalds wrote:
> On Tue, Nov 29, 2011 at 4:52 AM, Nixbits Admin <admin at nixbits.org> wrote:
>> While knowing that your time is precious and without wanting to making you
>> spend more than what you may be able to spare for my problem; i would like
>> ask you if you could take a look at this issue.
>> https://forums.gentoo.org/viewtopic-p-6885908.html#6885908
>> snd-usb-audio: probe of 2-2:1.0 failed with error -5
> This is related to the line above it:
>   Nov 29 07:21:21  kernel: skipping empty audio interface (v1)
>   Nov 29 07:21:21  kernel: snd-usb-audio: probe of 2-3:1.0 failed with error -5
> which in turn is because of a zero "bInCollection" value in the device
> control header. I'm adding some sound people to the cc, in case
> anybody has more clues about what's wrong with that particular device
> - I don't personally have any real clue about usb audio.

As the dump in the forum post doesn't decode any of the USB audio
specific headers, we'd need to see the output of "lsusb -v" with that
device connected.

If the driver bails out at this point, there's something wrong with the
descriptors, or the interface has no audio support at all (which would
be odd as it could have been omitted entirely in the first place).

We might have to add a quirk for the device, let's see.


More information about the Alsa-devel mailing list