[alsa-devel] Clevo P170HM / Sager NP8170 audio

Julian Sikorski belegdol at gmail.com
Thu Nov 24 11:03:08 CET 2011

W dniu 24.11.2011 10:20, Julian Sikorski pisze:
> W dniu 20.08.2011 09:33, Andrew Mahone pisze:
>> This laptop is detected as ALC892 audio (and by the codec ID this
>> seems to be valid), but none of the configurations for it quite match
>> this device. I've been working on documenting the connections with HDA
>> Analyzer.
>> alsa-info output:
>> http://www.alsa-project.org/db/?f=b86e4c6447867fbd129a36d8a63e2f5caa836c52
>> The laptop has built-in 5.1, and 5.1 or 7.1 output via jacks.
>> DAC NIDs:
>> 0x02 front
>> 0x03 rear
>> 0x04 clfe
>> 0x05 side
>> internal mixers:
>> 0x0c front
>> 0x0d rear
>> 0x0e clfe
>> 0x0f side
>> internal speaker pins:
>> 0x14 front
>> 0x15 "rear" (front of laptop)
>> 0x16 clfe
>> external ports:
>> fixed route:
>> 0x17 side
>> can select any output:
>> 0x18 mic / output
>> 0x1a line-in / output
>> 0x1b headphone
>> I've been experimenting with patch_realtek.c to add the extra DAC NID,
>> and have had some success with a 6-channel mode for the built-in
>> speakers and an 8-channel mode that mutes all internal speakers and
>> sets the jacks up for output. I still need to manually connect pins
>> 0x18, 0x1a, 0x1b to the correct internal mixers for 7.1 to work, and
>> headphone plugin does not mute internal speakers in 5.1 mode. I have
>> not added a plain stereo mode for internal speakers, although it
>> appears that i can probably configure the codec to mix the front
>> channels to center and LFE.
>> Are there any suggestions for what to do next? My current state as a
>> patch against the linux-3.0.y repository is at
>> http://pastie.org/2400649
> I tried this patch (attached a version ported to 3.1.x kernel) with
> P150HM and I was still unable to get sound out of the subwoofer when on
> 6 channel mode, could nonexisting rear be interfering?

I tried a similar patch but also no luck there... Any ideas why the
subwoofer might not be working? Is there a way to somehow eavesdrop the
windows driver?

> As Andrew said, 8 channel mode works once you manually unmute and
> reattach mixers using hda-analyzer.
> Regards,
> Julian

-------------- next part --------------
A non-text attachment was scrubbed...
Name: clevo-p150hm-quirk.patch
Type: text/x-patch
Size: 3114 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20111124/a469e337/attachment.patch 

More information about the Alsa-devel mailing list