[alsa-devel] First test of the hda-jack branch

Takashi Iwai tiwai at suse.de
Mon Nov 21 14:38:33 CET 2011

At Mon, 21 Nov 2011 11:02:11 +0100,
David Henningsson wrote:
> On 11/17/2011 05:39 PM, Takashi Iwai wrote:
> > At Mon, 14 Nov 2011 10:32:07 +0100,
> > Takashi Iwai wrote:
> >>
> >>> In addition, I have a question about the second machine, which looks
> >>> like this:
> >>>
> >>> numid=45,iface=CARD,name='Front Headphone Jack'
> >>> numid=47,iface=CARD,name='Front Mic Jack'
> >>> numid=48,iface=CARD,name='Line Jack'
> >>> numid=41,iface=CARD,name='Line-Out Jack'
> >>> numid=42,iface=CARD,name='Line-Out Jack',index=1
> >>> numid=43,iface=CARD,name='Line-Out Jack',index=2
> >>> numid=44,iface=CARD,name='Line-Out Jack',index=3
> >>> numid=46,iface=CARD,name='Rear Mic Jack'
> >>>
> >>> Would it be possible to name the Line-Out Jacks "Front Line-Out",
> >>> "Surround Line-Out" etc, so one can tell which one is which? Or can you
> >>> always tell that just from the order of them?
> >>
> >> I can assign more intuitive names for the output, certainly.
> >> I'll consider the implementation.
> >
> > I added more commits there for a bit better control names.
> > The function got messy and I'd need to rewrite sometime later, but
> > would like to complete the feature at first.
> >
> > Note that along with the development, I had to rebase this branch so
> > that it can be merged easily to the latest tree.  Please be careful
> > when you pull to the existing branch.
> Thanks! I've only had a quick look so far (no real test yet), I have 
> some thoughts though:
> 1) I like the idea of having location prefix and channel mapping suffix! 
> With this implementation we also seem to avoid things like "Front 
> Line-Out Rear" and "Rear Line-Out Front" which could have been 
> confusing, so well done :-)
> 2) I saw that headphones were not handled differently, for dual 
> headphones, could they be called e g "Headphone Front Jack" and 
> "Headphone Surround Jack" even they both play the front channel?

Good point.  Fixed now.

This reminds me of the handling of two speaker pins.  As far as I've
seen, all hardware with two speaker pins are for a speaker + a
bass-speaker.  Thus, heuristically, we should assign "Speaker" and
"Bass Speaker" or such.

> 3) For HDMI I added a while ago something to make it possible to 
> associate the HDMI Jack name with the correct PCM device. We must do the 
> same for the kctl implementation, or it will not be possible to 
> distinguish them correctly. I suggest we do like with the ELD control 
> here, and set the "device" of the kcontrol to 3,7,8 or 9. Do you agree? 
> (We can also add this number somewhere in the name, which might be 
> simpler but maybe less elegant.)

The consistency is important in this case, indeed.

> 4) "Surround" is misspelled in check_output_sfx.

Thanks, fixed this now, too.


More information about the Alsa-devel mailing list