[alsa-devel] Dell XPS 13 (Codec: IDT 92HD73C1X5) and 3 stereo jack output

Ruben Van Boxem vanboxem.ruben at gmail.com
Sun May 29 21:42:56 CEST 2011


I have been trying to get my Dell XPS 13 to output 5.1 sound through
the stereo jacks (because the NVIDIA HDMI only does 2.1). Attached is
alsa-info output. I can't seem to be able to set the Line/Mic In to

I have tried several things, going from fiddling with Kmix to fiddling
with the modprobe "model=" parameter, and even looking through the
hda_analyzer.py output. This last one lifted a tiny corner of the
solution, but I don't think a vanilla Alsa install will get me through

In Windows, I can use the three jacks to output 2 channels each, so I
am sure the hardware is capable of it. In HDA analyzer I can see that
there are several "Line Out" entries, but since they all have the node
cap "Unsolicited Capabilities", I'm pretty sure the problem is alsa
not knowing about the, well, capabilities.

I searched the web and documentation for anything sane to try, but
nothing worked. The default modprobe "model=" is the best (I can get
4.0 output from the jacks, and everything works, except the third

If you need more input or information, please ask, I'm very willing to
get this solved!


-------------- next part --------------
A non-text attachment was scrubbed...
Name: alsa-info.zip
Type: application/zip
Size: 5586 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110529/9570bdad/attachment.zip 

More information about the Alsa-devel mailing list