[alsa-devel] Multiple sound problems with ALC888 (1025:013f) on Acer Aspire 5930

Elisavet Vorgia elisavet_vorgia at yahoo.gr
Wed Mar 30 10:54:10 CEST 2011

Hi All,

I have sound issues with my laptop, I cannot get 5.1 sound and jack 
sensing does not work (but works on Windows 7; dual-boot).

I have an Acer Aspire 5930 (chipset: ALC888) running Ubuntu 10.10 (64-bit).
I have tested with Alsa 1.0.23 (which comes with Ubuntu 10.10) and also
compiled Alsa 1.0.24.
Here is the Alsa-info with Alsa 1.0.24 (latest), and "model=auto",
http://www.alsa-project.org/db/?f=2cbab ... 31dc6a7d70 

Here is alsa-info with "model=acer-aspire-6530g",
http://www.alsa-project.org/db/?f=40992 ... 17160cde64 

However, on Linux,
1. the sound volume is too low compared to Windows 7. For example,
     50% on the volume bar in Ubuntu is roughly equivalent to 10% in 
Windows 7.
2. the subwoofer control bar in Sound Preferences Settings seems to 
control the master volume bar.
3. it seems that only 2 speakers actually work (Front Left and Front 
Right) as tested with speaker-test -c6 -twav
4. when I plug in the headphones jack the internal speakers don't get 
muted, instead I have combined sound output.

I tried to change the model from auto to "acer" (tested all the acer and 
the 6stack-dig models
and settled down to acer-aspire-6530g as a popular suggestion) but it 
didn't change much.
(You'll find the alsa-info.txt as an attachment to this message.)

Is there any possible solution or suggestion for this problem?
I am happy to try out patches.


More information about the Alsa-devel mailing list