[alsa-devel] snd-bt87x unknown soundcard, detected but no sound.

Grzegorz Orciuch g.orciuch at gmail.com
Wed Mar 23 11:26:46 CET 2011

I've the TV card which is Kworld KW-TV878RF and tv module bttv gives
the vision well.
It registers also the sound device in lspci -vv:
01:08.1 Multimedia controller: Brooktree Corporation Bt878 Audio
Capture (rev 11)
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (1000ns min, 63750ns max)
Interrupt: pin A routed to IRQ 3
Region 0: Memory at f8000000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
pcilib: sysfs_read_vpd: read failed: Connection timed out
Not readable
Capabilities: [4c] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
then I load the module snd-bt87x with no argument, then it says the
card is not detected.
Then I load the module as "modprobe snd-bt87x load_all=1
digital_rate=44100" (also 32k is not giving sound)
ALSA sound/pci/bt87x.c:866: unknown card 0x878-0x00:0x00
ALSA sound/pci/bt87x.c:869: please mail id, board name, and, if it
works, the correct digital_rate option to
<alsa-devel at alsa-project.org>
Bt87x 0000:01:08.1: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ALSA sound/pci/bt87x.c:937: bt87x0: Using board 0, analog, digital
(rate 44100 Hz)
Can you somehow help me ? Now I'm going to connect audio-out with
soundblaster line-in, as workaround.

More information about the Alsa-devel mailing list