[alsa-devel] Microphone not working on PCI ID 8086:3b56

Jeff Chua jeff.chua.linux at gmail.com
Fri Mar 18 18:55:10 CET 2011

On Sat, Oct 2, 2010 at 1:10 AM, Jeff Chua <jeff.chua.linux at gmail.com> wrote:
> On Fri, Oct 1, 2010 at 6:18 PM, Takashi Iwai <tiwai at suse.de> wrote:
>>> Getting closer, but mic still not working.
>> Jeff, give always alsa-info.sh output when you want someone else
>> looking into your HD-audio problem.  Without it, it's very hard to
>> follow what is wrong.
>> So, the mic is detected.  I guess you didn't set up the capture mixer
>> and else properly.
> Attached is the alsa-info output. I used alsamixer to set the Analog
> mic boost to 40db, and I can also see that alsa is detecting the
> external mic when I plug the mic in.
> - ALSA sound/pci/hda/patch_conexant.c:2354: CXT5066: external microphone absent
> + ALSA sound/pci/hda/patch_conexant.c:2348: CXT5066: external
> microphone detected
> Still no sound.

I just want to update you all now that I finally got the mic to work
on my X201s. It's the settings in the BIOS. Unlike earlier Thinkpad
models, the X201s BIOS has a special setting to enable/disable the
mic.  Bios setup: F1 -> Security -> I/O Ports -> Microphone -> Enable.
Since I trashed Windows on the X201s as soon as I power up the first
time  that could have disabled the mic by default.

Now, it's all working.

Thanks for all you help!


More information about the Alsa-devel mailing list