[alsa-devel] SBx00 Azalia ALC663 Working but MIC goes away

Diego Jacobi jacobidiego at gmail.com
Thu Jun 30 05:15:06 CEST 2011

Thanks Takashi and Paul for your help.

It worked.

All the Front panel is working perfectly now.
Only my internal MIC is not working at all, but i dont care for it.

I had to follow the instructions from here:


I didnt knew my kernel was updated, or didnt remembered and the
instructions provided are not very clear, too repetitive for almost
the same thing.

For the records:

search for the kernel-default in the software installer aplication,
and see under versions, if the repository is the OSS or the Updates.
If the second one, then do:

# zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.4_Update/

# zypper install alsa-driver-kmp-default

# zypper rr multimedia

check if it is correctly installed with:

# modinfo snd-hda-intel | grep filename


Note: The update name of the repo, and the updates folder in the
kernel modules directory.

I dont know why we need to remove the repo, or if the updated driver
will be automatically updated on newer kernels or not.
But this update solved my issues.

I am unsubscribing now.


2011/6/28 Takashi Iwai <tiwai at suse.de>:
> At Tue, 28 Jun 2011 10:33:50 -0300,
> Diego Jacobi wrote:
>> I already sended this mail to this list ... many times .. but it gets
>> bounced or wait for moderation. I find this annoying.
>> I am attaching the files compressed now.
> Thanks, but please don't cross-post both to alsa-devel and alsa-user.
>> I tested the solution mentioned by Takashi.
>> I have installed alsa-driver-kmp-default and restarted, but i found
>>  the same behavior so, i didnt make more alsa-info files.
>> However, i dont know what is "the right repository",
> Did you read the Wiki page there?  There are detailed descriptions
> there...
>> i choosed "multimedia:audio:KMP/openSUSE_11.4"
>> and also tested "multimedia:audio:KMP/openSUSE_11.4_Update" which
>> provided the same file.
> No, they definitely provide different files.  If you are using the
> updated 11.4 kernel, use openSUSE_11.4_Update repo, in general.
>> The file is installed in
>> linux-i1zx:/home/diego # modinfo snd-hda-intel | grep filename
>> filename:
>> /lib/modules/
> So the KMP module is *not* used there, thus further test results are
> useless, unfortunately.
> Takashi

More information about the Alsa-devel mailing list