[alsa-devel] Realtek ALC662 rev1 no sound over HDMI

Stephen Warren swarren at nvidia.com
Mon Jun 27 22:06:17 CEST 2011

Crow wrote at Monday, June 27, 2011 11:49 AM:
> >> At Sun, 26 Jun 2011 18:45:30 +0200, crow wrote:
> >> >
> >> > I am trying to get sound working on kernel 2.6.39 (under archlinux
> >> > x86_64 bit distribution) over HDMI to my digital receiver but without
> >> > luck. Before this post i asked in #alsa for help, and everything we
> >> > tried over there didnt get the sound over HDMI.
> >> > I connected headphones to the green jack and ran speaker-test and
> >> > there is sound over jack, analog sound plays fine. But runing
> >> > alsamixer un-muting spdif/iec958/spdif (1) and trying to re run
> >> > speaker-test doesn't output sound over HDMI to my digital receiver.
> I dont have any GUI here, trough i installed xorg,nvidia,alsa and
> prepared for VDR/XBMC.

I don't quite understand that last sentence. Just to be clear, audio over
HDMI isn't expected to work unless the NVIDIA binary X driver is installed,
X is running, and X is being displayed over HDMI.

> Well I must mark this as solved. Inside .xine/config i have :hdmi as
> output device defined, and i get sound on my speakers using just HDMI
> as connection to my digital receiver.
> I actualy didnt test it before with xine, and was trying just
> speaker-test which seems could not output sound over :hdmi (0,3).
> Maybe there is bug in speaker-test, but then after getting it work
> with xine i could test it with speaker-test to..
> Then i reboted my htpc and got it.. It seems HDMI output isnt
> activated, or speaker-test cant activate it somehow..
> $ speaker-test -c 2 -r 48000 -D hw:0,3
> $ speaker-test -c 2 -D hw:0,3
> Both above command dont work after first boot. And with aplay i get
> this (command from 13.7. Test Playback With ALSA Physical Devices (1):
> aplay -D hw:0,3 /usr/share/sounds/alsa/Front_Center.wav
> Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit
> Little Endian, Rate 48000 Hz, Mono
> aplay: set_params:1065: Channels count non available
> But if i run xine, which connects to VDR i get sound, and after
> killing xine, and re-run speaker-test i got audio over HDMI just
> fine...
> $ speaker-test -c 2 -r 48000 -D hw:0,3
> $ speaker-test -c 2 -D hw:0,3

That's odd. I don't understand why running xine first would help.

Perhaps you could try compiling the very latest ALSA kernel driver code,
and seeing if that makes any difference? Recently, some changes were made
in the way the HDMI audio infoframes get set up for the chipset you're


More information about the Alsa-devel mailing list