[alsa-devel] snd_pcm_link : Function not implemented

ashwanik ashwani.kumar at freesystems.biz
Thu Jun 16 13:09:04 CEST 2011

On Thursday 16 June 2011 04:13 PM, Takashi Iwai wrote:
> At Wed, 15 Jun 2011 05:50:29 +0000 (UTC),
> Ashwani Kumar wrote:
>> ashwanik<ashwani.kumar<at>  freesystems.biz>  writes:
>>> Hi All,
>>> I have download and compile latency.c application from
>>> http://www.alsa-project.org/alsa-doc/alsa-lib/_2test_2latency_8c-example.html.
>>> This application is  working fine on  Linux PC.
>>> But when I am using this application on my omap4 board(using
>>> ubuntu10.10) is not working.
>>> I am getting"Streams link error: Function not implemented" error. I
>>> debug the application and found this error coming from the
>>> *snd_pcm_link* function.
>>> I am using ALSA Driver Version 1.0.23.
>>> please find pointers.
>>> Thanks in Advance
>>> Ashwani
>> Hi,
>> Bringing to Top ,anyone faced similar problem of "snd_pcm_link" returning error
>> val=-38 and prints "Streams link error: Function not implemented".
> I don't know of such a problem.  Better to check what went wrong via
> strace or such.
> Takashi
Thanks for your reply,

I left that application(latency.c).
now i have merged alsa playback and capture application and thats 
working with following issue on omap4 board:
 > when i am executing this apps getting "underrun occurred" error
 > CPU consumption very high 22 - 27%.

please help to sort-out above problems.

Thanks in advance

More information about the Alsa-devel mailing list