[alsa-devel] [PATCH] ASoC: pcm - rename snd_codec_close() to snd_pcm_close().

Takashi Iwai tiwai at suse.de
Fri Jun 10 08:07:30 CEST 2011


At Thu, 9 Jun 2011 17:04:59 +0100,
Liam Girdwood wrote:
> 
> Make sure we follow naming convention for all PCM ops.

The subject contain typos :)


Takashi

> 
> Signed-off-by: Liam Girdwood <lrg at ti.com>
> ---
>  sound/soc/soc-pcm.c |    4 ++--
>  1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/sound/soc/soc-pcm.c b/sound/soc/soc-pcm.c
> index f4864b0..b575939 100644
> --- a/sound/soc/soc-pcm.c
> +++ b/sound/soc/soc-pcm.c
> @@ -268,7 +268,7 @@ static void close_delayed_work(struct work_struct *work)
>   * freed here. The cpu DAI, codec DAI, machine and platform are also
>   * shutdown.
>   */
> -static int soc_codec_close(struct snd_pcm_substream *substream)
> +static int soc_pcm_close(struct snd_pcm_substream *substream)
>  {
>  	struct snd_soc_pcm_runtime *rtd = substream->private_data;
>  	struct snd_soc_platform *platform = rtd->platform;
> @@ -567,7 +567,7 @@ static snd_pcm_uframes_t soc_pcm_pointer(struct snd_pcm_substream *substream)
>  /* ASoC PCM operations */
>  static struct snd_pcm_ops soc_pcm_ops = {
>  	.open		= soc_pcm_open,
> -	.close		= soc_codec_close,
> +	.close		= soc_pcm_close,
>  	.hw_params	= soc_pcm_hw_params,
>  	.hw_free	= soc_pcm_hw_free,
>  	.prepare	= soc_pcm_prepare,
> -- 
> 1.7.4.1
> 
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel
> 


More information about the Alsa-devel mailing list