[alsa-devel] [PATCH] thinkpad-acpi: Enable microphone mute LED

Takashi Iwai tiwai at suse.de
Fri Jun 3 17:50:42 CEST 2011

At Fri, 27 May 2011 14:22:26 -0400,
Andrew Lutomirski wrote:
> On Fri, May 27, 2011 at 12:48 PM, Matthew Garrett <mjg59 at srcf.ucam.org> wrote:
> > On Fri, May 27, 2011 at 12:39:10PM -0400, Andrew Lutomirski wrote:
> >
> >> I don't have docs so I don't really know.  But the mute LED does not
> >> appear to be controllable from the LED interface and when mute is lit
> >> there's no sound regardless of what ALSA thinks.  When I light the
> >> micmute light, I can still record sound just fine.
> >>
> >> The mic mute button does nothing on Windows unless the special driver
> >> is installed, and that driver seems to mute the Windows mixer, so I
> >> think there's nothing special other than a little userspace helper
> >> going on.
> >
> > Hm. That makes things kind of tricky. While it's easy to just expose the
> > LED, really we want to do it in such a way that userspace knows which
> > LEDs it should be toggling while setting the microphone mute.
> One thought: call the thing laptop::micmute and teach userspace to
> look for an led with that name.
> Do any of the ALSA or PulseAudio people have any preferences?

I don't know of any machines but Thinkpad providing such a LED
control, so I'm fine with any naming basically :)  Though, if there
are many of such mute LEDs, any parseable form like laptop::xxx-mute
would be better for future?



More information about the Alsa-devel mailing list