[alsa-devel] M-Audio FTU issues

Juan Pablo Bouza jpbouza at hotmail.com
Sat Jul 23 06:25:39 CEST 2011

Thanks for the reply Daniel!

Well, I've patched and compiled Takashi's kernel... still no luck, no playback.
The good thing is that I also compiled this same kernel without patching and playback did work, so I assume there's something wrong with the patch I'm applying??

What I do is simply opening Audacity and trying to play a sound file. With the patched kernel Audacity says that it can't open the device for playback. I also tried jack and it won't start in playback or duplex mode.
As I said, recording does work ok.... And also, the kernel without patching works in all modes.

So... can you give me a link to the patch, just in case the patch I'm using has something wrong (although no errors are displayed when patching)

Secondly, is there a way I can debug the playback error? Some command line that could tell me why it can't open the device?

By the way, I'm in Kubuntu 10.04 and I'm compiling the kernel with kernel-package 12.036.

Sorry for being such a pain!! Thanks!!

PS: here's the output of the patching process:

root at ARTURITO:/usr/src/sound-2.6# patch -p1 <86547-001.bin 
patching file include/linux/usb/ch9.h
patching file sound/usb/card.h
patching file sound/usb/pcm.c
patching file sound/usb/pcm.h
patching file sound/usb/quirks.c
Hunk #1 succeeded at 753 (offset 109 lines).
patching file sound/usb/urb.c
patching file sound/usb/urb.h
root at ARTURITO:/usr/src/sound-2.6# 

> Date: Fri, 22 Jul 2011 10:42:26 +0200
> From: zonque at gmail.com
> To: jpbouza at hotmail.com
> CC: gdiffey at gmail.com; tiwai at suse.de; clemens at ladisch.de; alsa-devel at alsa-project.org; linuxaudio at showlabor.de; blablack at gmail.com
> Subject: Re: [alsa-devel] M-Audio FTU issues
> On Thu, Jul 21, 2011 at 10:31 PM, Juan Pablo Bouza <jpbouza at hotmail.com> wrote:
> >
> > Yes, I know about the duplex mode kernel crash... But anyway, playback is just broken with the patch and my compilation...
> All others reported success on this. Are you really playing a plain .wav file?
> > Against what version of kernel 3 is the patch supposed to work?
> On top of Takashi's master branch:
> git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git
> > Is there any additional kernel configuration option I should or should not use in order to make the patch work??
> You should have of course have a kernel which does in general support
> the FTU, but nothing more.
> Daniel
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

More information about the Alsa-devel mailing list