[alsa-devel] model needed for Clevo P150HM (Realtek ALC892)

Julian Sikorski belegdol at gmail.com
Fri Jul 1 13:18:00 CEST 2011

On 01/07/2011 09:14, Takashi Iwai wrote:
> At Fri, 01 Jul 2011 09:07:47 +0200,
> Julian Sikorski wrote:
>>>>>>> So it seems that the only things remaining are the SPDIF/rear channel
>>>>>>> jack and the coupled muting issue.
>>>>>> It's a BIOS bug.  It doesn't tell SPDIF is available.
>>>>>> Ditto for the 4th stereo out.  No pin is exposed by BIOS.
>>>>> I see. I can try updating the BIOS and see if it changes anything. If it
>>>>> doesn't, is there a way to work the problem around in the driver?
>>>> You need to figure out pins manually by yourself, then change the
>>>> driver code.  I leave it as a homework :)
>>> :) I cannot write code, so I would not count on myself doing that. I
>>> will have a look into updating the BIOS though.
>>>> thanks,
>>>> Takashi
>>> Once again thanks for all the work you have done,
>>> Julian
>> Hmm, I googled a bit and it seems the way to find the pins is to write
>> values to user_pin_configs. So no coding knowledge seems needed, could
>> you give me some pointers on where to start?
> First off, read the HD-audio specification to understand what the values
> represent.  Then, use hda-analyzer or manually via hda-verb, figure out
> which widget corresponds to which I/O jack.  Compose the corresponding
> pin-config value, and put it to the sysfs file.  A brief description
> is found in Documentation/sound/alsa/HD-Audio.txt.
> Takashi
I was reading a bit more and it is all very confusing, but luckily I 
have holidays coming to try and figure it out. In the meantime, should I 
also try to find the pin for the internal subwoofer?
WRT the alsa-info.sh output I'll send it once I get home later today.


More information about the Alsa-devel mailing list