[alsa-devel] [PATCH] ASoC: Add dependency on X86 for Intel MID drivers

Alan Cox alan at linux.intel.com
Mon Jan 17 11:15:30 CET 2011

On Sat, 15 Jan 2011 13:28:42 +0000
Mark Brown <broonie at opensource.wolfsonmicro.com> wrote:

> On Sat, Jan 15, 2011 at 06:55:57PM +0530, Koul, Vinod wrote:
> > X86 specifies generic x86 devices, pc's netbooks.....
> > The MID class of devices are quite different, so IMO it should
> > rather depend on X86_MRST which is for MID devices.
> > CC Alan:
> > Alan would X86_MRST be apt or any other option for MID drivers vs
> > X86?

That depends what it needs - you want to specify the minimum needed to
make it buildable really, which is probably INTEL_SCU_IPC in this case
- you use the IPC I/O so you need the IPC, and the rest follows.

More information about the Alsa-devel mailing list