[alsa-devel] Adding a "capture" device naming scheme
tiwai at suse.de
Wed Jan 12 07:53:26 CET 2011
At Wed, 12 Jan 2011 09:08:37 +0800,
Raymond Yau wrote:
> 2011/1/12 Colin Guthrie <gmane at colin.guthr.ie>
> > Hi,
> > As has been pointed out a few times, it's incorrect to use "front:" for
> > capture, but can we have an official name/wrapper (I'm unsure of the
> > terminology here) for this so we don't use hw: for recording?
> > I'd be in favour of "capture:" or "input:" as these both seem quite
> > logical and easy to understand.
> > It would be used thusly:
> > arecord -f S16_LE -c 2 -D capture:CARD=Intel
> > as opposed to the incorrect:
> > arecord -f S16_LE -c 2 -D front:CARD=Intel
> > or the low level:
> > arecord -f S16_LE -c 2 -D hw:CARD=Intel
> why do you think that it is incorrect to use hw:CARD=xxx for analog capture
I read Colin meant front:CARD=x is incorrect while hw:CARD is a lowlevel
access that one doesn't always want.
I'm fine with creating a new name, but wondering which name is best.
Basically what you want here is the default use-case but without
dsnoop like the current "default". (If dsnoop were acceptable,
"default" should have been used in most places.)
"capture" may be also too ambiguous for defining that, I'm afraid.
More information about the Alsa-devel