[alsa-devel] Adding a "capture" device naming scheme

Colin Guthrie gmane at colin.guthr.ie
Tue Jan 11 19:40:01 CET 2011


As has been pointed out a few times, it's incorrect to use "front:" for
capture, but can we have an official name/wrapper (I'm unsure of the
terminology here) for this so we don't use hw: for recording?

I'd be in favour of "capture:" or "input:" as these both seem quite
logical and easy to understand.

It would be used thusly:

  arecord -f S16_LE -c 2 -D capture:CARD=Intel

as opposed to the incorrect:
  arecord -f S16_LE -c 2 -D front:CARD=Intel
or the low level:
  arecord -f S16_LE -c 2 -D hw:CARD=Intel

Keeping it wrapped up allows for e.g. softvol or other things to be
plugged in as appropriate in the config and thus future proofs things a

If someone could point me roughly in the right direction I'll make a
patch. I suspect it'll be easy enough to cook up the relevant config
needed (and I suspect it's just config rather than code that needs
patched, but I could be wrong).

It would be nice to get this into a release (alsa-lib?) soon so that it
can propigate and we can require it.




Colin Guthrie

Day Job:
  Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
  Mageia Contributor [http://www.mageia.org/]
  PulseAudio Hacker [http://www.pulseaudio.org/]
  Trac Hacker [http://trac.edgewall.org/]

More information about the Alsa-devel mailing list