[alsa-devel] snd-usb-audio dying on jackd xruns

Rods Bobavich rodnisms at gmail.com
Wed Feb 2 17:54:24 CET 2011

So I start jackd and it runs fine for a while. Then ALSA crashes and
triggers an xrun. Jackd continues to do its merry thing - minus the part
about spitting info out to my soundcard...

At first I thought this was a Jackd issue but when I looked deeper it seems
to be ALSA. Once this happens I cannot restart jackd and resume an audio
session. In fact, I cannot even rmmod snd-usb-audio. Sometimes I cannot
lsusb. So it looks like something is getting seriously hosed!

It seems to be specific to my machine.

I've tried multiple usb intefaces. All work fine with other computers. I've
tried multiple version of Ubuntu with various versions of ALSA on this
machine. All exhibit the same behavior. I have 3 other machines that run
these interfaces just fine... So it seems to be a
hardware compatibility issue not a software glitch in one version.

I've tried many boot flags but to no avail. I'm at a loss on how to

The machine is M4N75TD motherboard with a Phenom II 1055T and the latest
bios flash.

Please advise,

...Rods ;-)

More information about the Alsa-devel mailing list