[alsa-devel] [PATCH 0/6] snd-usb endpoint rework, version 6

Aurélien Leblond blablack at gmail.com
Sat Dec 31 16:02:09 CET 2011

> OK, it doesn't work for me. Each time I try to start a stream I get
> error messages like this:
> cannot submit urb 0, error -28: not enough bandwidth

Hi Felix,

Is this when using the FTU or another USB device?

Would your USB device by any chance be of type USB 1, and the type of
the USB port on your machine EHCI?

If so, could it be related to this problem?

There used to be a problem with EHCI and USB1 soundcards.
I never got my Edirol UA-25Ex to work on my machine, gettting the
exact same error as the one you described.

But, few weeks ago, while testing the RC 3.2 kernel with Daniel's
patch, it worked.
I don't believe Daniel's patch fixed the problem, but more the changes
done in 3.2 by Clemens.

Now, after more testing, it turns out my Edirol UA25-Ex works only if
I have a pretty high latency on Jack (25ms).
If I try and decrease the Frames/Period, then the bandwitdh issue
occurs again (mind me, it's way better then before where the sound
card wouldn't work in Full Duplex)...

Hope this helps,

More information about the Alsa-devel mailing list