[alsa-devel] [PATCH 0/5] RFC v2 for snd-usb endpoint logic rework

Aurélien Leblond blablack at gmail.com
Fri Dec 9 22:00:51 CET 2011

Hi Daniel,

Compiled and running!
So far so good! I haven't pushed the jack parameters more than I would
usually though... I'm still at 16ms latency (Frame/period: 256 ;
Sample Rate: 48000 ; Periods Buffer: 3).
That was the minimum I could go with the previous driver, so I'll try
to push it a bit tomorrow and see how it goes.
Is there any particular testing you would like to see done?

Another thing, in your previous post, you asked to try the driver with
other sound card.
I have an Edirol UA-25Ex that never worked on this machine (I have the
dredded EHCI USB port, it's the reason why I bought the FTU in the
first place).
The error I used to get while starting Jack in Full Duplex with this
sound card was
"Cannot submit datapipe for urb 0, error -28: not enough bandwidth"

But, "apparently".......now it works!
I tried it not later than last week with Kernel 3.0 and it still wasn't working.

But with 3.2 and your patch, (and after running the FTU on the very
same USB port), I got the UA-25Ex to work in full duplex for the first
time ever.

I don't know if it is due to the new version of the kernel, or your
patch, or something else, but this is huge because a lot of people
used to have this problem with EHCI and USB 1 sound cards.
(or may be it was simply fixed between 3.0 and 3.2 and I simply missed it!).

So the second question is: what do you think?
Any info you would like to see posted here? (dmesg trace....anything else?).

Anyway, thanks a lot for everything :)


On Thu, Dec 8, 2011 at 7:38 PM, Daniel Mack <zonque at gmail.com> wrote:
> Hi Aurélien,
> On 12/08/2011 08:33 PM, Aurélien Leblond wrote:
>> I finally got some time to test this driver!
>> I'm not sure I understand where to get Takashi's sound tree.
>> I tried to apply your patch against a clone of
>> git://git.alsa-project.org/alsa-kmirror.git alsa-kmirror, but then
>> GitCompile failed.
>> I then tried to use
>> git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git , but
>> I'm not even sure what I'm pulling to be honest...
>> Would you mind just guiding me on how to prepare the source code?
> No problem :)
> Clone Linus' tree:
>  git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
> Make a local branch and pull in Takashi's tree:
>  cd linux
>  git checkout -b alsa
>  git pull git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git
> master
> Make another branch on top of that
>  git checkout -b usbaudio
> Then apply my patch(es). For the next round, just kill the local
> usbaudio branch again and start over:
>  git reset --hard
>  git checkout alsa
>  git branch -D usbaudio
>  git checkout -b usbaudio
> Then apply the next round :)
>> Thanks in advance, and thanks for all the work you have already done!
> No problem. I'm planning to continue work on this these days. It's just
> that I'm constantly distracted by other things :-/
> Daniel

More information about the Alsa-devel mailing list