[alsa-devel] Compiler warning - overriding codec compress type

Mark Brown broonie at opensource.wolfsonmicro.com
Mon Apr 18 12:30:57 CEST 2011

On Sun, Apr 17, 2011 at 11:37:34PM -0700, Patrick Lai wrote:

> I got a compiler warning soc-core.c: In function 
> 'snd_soc_instantiate_cards' warning: 'compress_type' may be used 
> uninitialized in this function. In reality, compress_type is defined as 
> local variable in snd_soc_instantiate_card().

Please *always* CC relevant maintainers on mails if you want them to be

> My kernel version is 2.6.38. Has the warning being addressed in 2.6.39 
> or 2.6.40 patches? If not, after tracing through the code, I think the 
> fix should look like the following:

This is the sort of question that can easily be answered by building the
code...  I believe it's not an issue with current code but I've not
looked myself.

More information about the Alsa-devel mailing list