[alsa-devel] Conexant CX20585 recording does not work

David Henningsson david.henningsson at canonical.com
Thu Apr 7 16:31:34 CEST 2011

On 2011-04-07 15:21, Gabriel Schulhof wrote:
> Hi!
> On Thu, April 7, 2011 15:42, David Henningsson wrote:
>> Please try the model quirk "hp-laptop". In Ubuntu that would be adding
>> the line:
>> options snd-hda-intel model=hp-laptop
>> to the file /etc/modprobe.d/alsa-base.conf
> Tried it. It did streamline the options available in alsamixer, but it
> didn't make recording work.
> I tried the skype test call, as well as arecord, and both did not only not
> record anything, but they didn't even record static. That is, the
> recording device seems to block! For example, the skype test call beeps
> before it plays back my recorded voice, and afterwards. Well, the two
> beeps were consecutive for me :(
> Also, arecord with no options outputs to the terminal. It output the
> header for the sound file, but the cursor did not start to fly across the
> terminal drawing all kinds of junk.
> Thanks a lot for your help,

I saw you had an AMD/ATI controller of the type we're discussing in 
parallel in the thread about "HDA record fails with FIFO error", it 
might be that you're bitten by that bug as well...

David Henningsson, Canonical Ltd.

More information about the Alsa-devel mailing list