[alsa-devel] [PATCH 2/2] ASoC: rename dapm_generic_apply_power()

Lu Guanqun guanqun.lu at intel.com
Sat Apr 2 09:23:36 CEST 2011


dapm_generic_apply_power() is only called in dapm_seq_run() when w->id is
snd_soc_dapm_{input|output|hp|line|mic}. So, it's not a generic function at
all, we better rename it to reflect what it's doing.

Signed-off-by: Lu Guanqun <guanqun.lu at intel.com>
---
 sound/soc/soc-dapm.c |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/sound/soc/soc-dapm.c b/sound/soc/soc-dapm.c
index d511bbe..9b7ac3f 100644
--- a/sound/soc/soc-dapm.c
+++ b/sound/soc/soc-dapm.c
@@ -605,10 +605,10 @@ int dapm_reg_event(struct snd_soc_dapm_widget *w,
 }
 EXPORT_SYMBOL_GPL(dapm_reg_event);
 
-/* Standard power change method, used to apply power changes to most
- * widgets.
+/*
+ * power change method, used for input, output, hp, line, spk, mic.
  */
-static int dapm_generic_apply_power(struct snd_soc_dapm_widget *w)
+static int dapm_input_output_apply_power(struct snd_soc_dapm_widget *w)
 {
 	int ret;
 
@@ -947,7 +947,7 @@ static void dapm_seq_run(struct snd_soc_dapm_context *dapm,
 		case snd_soc_dapm_line:
 		case snd_soc_dapm_spk:
 			/* No register support currently */
-			ret = dapm_generic_apply_power(w);
+			ret = dapm_input_output_apply_power(w);
 			break;
 
 		default:
-- 
1.7.2.3



More information about the Alsa-devel mailing list