[alsa-devel] how to mandate the use of PCM plugin?

Raymond Yau superquad.vortex2 at gmail.com
Tue Sep 28 03:01:19 CEST 2010

2010/9/28 Colin Guthrie <gmane at colin.guthr.ie>

> 'Twas brillig, and Stas Sergeev at 27/09/10 05:48 did gyre and gimble:
> >   Hello.
> >
> > 27.09.2010 04:58, Mark Brown wrote:
> >>> Is it possible to somehow mandate the
> >>> use of a PCM plugin? For example, the
> >>> PC-Speaker.conf defines the use of softvol
> >>> plugin for "default" and "front" devices.

if snd-pcsp only support mono and the pc speaker is also mono, by removing
"front" device from PC-Speaker.conf will force PA to user "hw"

The point is whether libcanberra ( system event sound) need snd-pcsp to
support stereo

I don't think other media application want to use this beep generator to
play music

More information about the Alsa-devel mailing list