[alsa-devel] mic on macbook air

Reimundo Heluani rheluani at gmail.com
Mon Sep 27 19:47:35 CEST 2010

On Mon, Sep 27, 2010 at 2:32 PM, Justin P. Mattock
<justinmattock at gmail.com> wrote:
> On 09/27/2010 09:40 AM, Reimundo Heluani wrote:
>> As far as I know I wrote the only patch for macbook air 2,1 that
>> shipped with 2.6.34 but that was for the internal speaker only. I
>> could never get the mic going.
>> Cheers,
>> R.
> when doing a cat codec#0 | grep Pin on my iMac9,1
> I can see:
> Node 0x19 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
>  Pincap 0x0000373c: IN OUT HP Detect
>  Pin Default 0x90a00110: [Fixed] Mic at Int N/A
>  Pin-ctls: 0x24: IN VREF_80
> when doing the same for the mba1,1 I didn't see anything in there that said
> Mic.. I'm wondering if the Mic is there, it's just not being shown when
> doing cat codec#0 due to apple changing something with the hardware. did you
> try different pin numbers?(even though none of the pins say Mic)
> Justin P. Mattock

Well, here it could just be my ignorance, but I think last year when I
was trying, I tried all possible pins and didn't find the mic
anywhere. Then I thought that it could be some vendor parameters on
0x20, but then I saw the plist file in the kext and the only thing
they adjust is the pindefault to 0x90a00110: [Fixed] Mic at Int N/A on
what it seems to be either pin 0x1c (which I tried) or 0x27 (which is
nonexistent). There's a thread at the ubuntu forums with people
running alsa on air 2,1 but I couldn't get anyone to play with



More information about the Alsa-devel mailing list