[alsa-devel] Need expert's advice - Fast Track Ultra (8R) dropping samples

Felix Homann linuxaudio at showlabor.de
Sat Sep 25 11:57:53 CEST 2010


in that past months I've been trying get the Fast Track Ultra devices 
working properly in Alsa. We've had lots of progress, most of the code 
has moved to Alsa git and today I've even posted a patch for getting 
mixer support for these devices.

Now, I need to get some expert's advice: The devices seem to drop 
samples or frames. Here's a report I've got today on the M-Audio forum:

"I've got a subtle problem to report: I think audio playback is dropping
sample frames. To hear the problem, open Audacity at 48 kHz and play
a 10-kHz. sine wave. When I do that I hear a regular clicking sound, about
four clicks a second. I've tried recording the output and if I'm seeing 
exactly one sample frame in every 13312 (13x1024) is being dropped on 
I don't see anything similar on input. When either jack or Pd has both 
the input and
the output open, the delay from input to output gradually decreases 
until it forces
occasional sync errors. (I haven't tried this with audacity though.)"


I could reproduce it on my machines, even at 44.1 kHz. The clicking 
sound is very subtle, it goes unnoticed when not listening to pure sines 
without attention to clicks.

How can this be sorted out. Any ideas?

Kind regards,


More information about the Alsa-devel mailing list