[alsa-devel] alsa-2.6.24

asim khan khan.asim.2009 at gmail.com
Wed Sep 1 05:50:34 CEST 2010


Iam using kernel 2.6.24 and trying run an ALSA capture application on arm11
this application when tries to open the device snd_pcm_open
(&capture_handle, "plughw:1,0",
SND_PCM_STREAM_CAPTURE, 0)) < 0)...it gives an error
ALSA lib pcm_hw.c:1399 _snd_pcm_hw_open) Invalid value for card
I have also tried using  device "hw:1,0" plughw:0,1...but it didnt help. I
get same error
then i checked /dev directory ,there it has not created /dev/snd directory
but I can see /dev/dsp0 dsp1,dsp2 ....which seems its not using ALSA as it
has not created /dev/snd .so I manually created the /dev/snd and the devices
like /dev/snd/pcmC0D0p and /dev/snd/controlC0. with major and minor number
as on x86 machine.same application is running well on x86

can anyone please help me in this that what could be the problem as soon as
possible..and what is solution for it....Thanks in advance


More information about the Alsa-devel mailing list