[alsa-devel] [RFC_iii/iv 1/2] ASoC: Rename dai_link as dev_map

Mark Brown broonie at opensource.wolfsonmicro.com
Fri Oct 29 23:22:49 CEST 2010

On Fri, Oct 29, 2010 at 03:02:59PM +0300, Jarkko Nikula wrote:
> Thus far the struct snd_soc_dai_link is used to tie together platform, codec
> and cpu dai drivers in a machine driver and all of these devices has been
> required for a link.

My main thought with this now that I see the change is that it'd be
easier and probably clearer to add an explicit list of devices rather
than to repurpose the DAI links.  This will probably be simpler since we
can avoid things like having to work out if we've seen and initialised a
device before when it has multiple DAIs involved.

More information about the Alsa-devel mailing list