[alsa-devel] HDA: no sound [was: mmotm 2010-10-20-15-01 uploaded]

Valdis.Kletnieks at vt.edu Valdis.Kletnieks at vt.edu
Thu Oct 21 17:22:49 CEST 2010

On Thu, 21 Oct 2010 09:57:16 +0200, Jiri Slaby said:
> On 10/21/2010 09:49 AM, Takashi Iwai wrote:
> > At Thu, 21 Oct 2010 09:41:08 +0200,
> > Jiri Slaby wrote:
> >> alsa-info:
> >> http://www.alsa-project.org/db/?f=a7a09703bcc8c43386c87a984e513ce35fc91ca4
> > 
> > I see the Front volume is set to zero.  Try to raise it.
> I set all the values to ~ 70 and then tried with pure alsa. It basically
> works.
> BUT, when I run pulse and it suspends the device (or whatever), all the
> levels get down to 0 back again. When I raise it and run mplayer, it
> gets to 0 immediately. If I raise it gets to 0 when mplayer finishes and
> pulse writes 'protocol-native.c: Connection died.'. It never raises
> automatically. And if I raise it during playback, nothing plays at all.

Seeing the same thing on a Dell Latitude E6500, so Jiri isn't hallucinating.

Didn't we have some flustercluck a while back that gave pulseaudio
similar indigestion?  Oh, here it is, it was an fsnotify botch, of all things.

commit 2069601b3f0ea38170d4b509b89f3ca0a373bdc1
Author: Linus Torvalds <torvalds at linux-foundation.org>
Date:   Thu Aug 12 14:23:04 2010 -0700

    Revert "fsnotify: store struct file not struct path"
    This reverts commit 3bcf3860a4ff9bbc522820b4b765e65e4deceb3e (and the
    accompanying commit c1e5c954020e "vfs/fsnotify: fsnotify_close can delay
    the final work in fput" that was a horribly ugly hack to make it work at

Did we manage to revert the revert, or re-break this code? I haven't looked at
this at all in detail.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 227 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20101021/4babada7/attachment-0001.sig 

More information about the Alsa-devel mailing list