[alsa-devel] HDA: no sound [was: mmotm 2010-10-20-15-01 uploaded]

Takashi Iwai tiwai at suse.de
Thu Oct 21 10:05:00 CEST 2010

At Thu, 21 Oct 2010 09:57:16 +0200,
Jiri Slaby wrote:
> On 10/21/2010 09:49 AM, Takashi Iwai wrote:
> > At Thu, 21 Oct 2010 09:41:08 +0200,
> > Jiri Slaby wrote:
> >> alsa-info:
> >> http://www.alsa-project.org/db/?f=a7a09703bcc8c43386c87a984e513ce35fc91ca4
> > 
> > I see the Front volume is set to zero.  Try to raise it.
> I set all the values to ~ 70 and then tried with pure alsa. It basically
> works.
> BUT, when I run pulse and it suspends the device (or whatever), all the
> levels get down to 0 back again. When I raise it and run mplayer, it
> gets to 0 immediately. If I raise it gets to 0 when mplayer finishes and
> pulse writes 'protocol-native.c: Connection died.'. It never raises
> automatically. And if I raise it during playback, nothing plays at all.

Hrm, I don't remember any so critical changes done recently in the
sound tree.  The only possibly affecting commits are:

  commit 1cc9e8f4c45999e6069f41521d9d391eeeccc3b3
    ALSA: hda - Fix codec muted after rebooting from Windows

  commit de8c85f7840e5e29629de95f5af24297fb325e0b
    ALSA: HDA: Sigmatel: work around incorrect master muting
Could you try to revert them?    



More information about the Alsa-devel mailing list