[alsa-devel] alsa-utils cross-compilation problem

Daniel Mack zonque at gmail.com
Tue Oct 19 01:03:29 CEST 2010

On 10/18/2010 08:52 AM, Reena Chauhan wrote:
> hi
> I had tried to cross compile the Alsa-utils 1.0.23&  m getting following
> errors:
> checking for libasound headers version>= 1.0.16... not present.
> configure: error: Sufficiently new version of libasound not found
> In my host PC alsa-lib 1.0.22 is installed

You need to cross-compile alsa-lib as well and then point the build 
process of alsa-utils to the correct pathes.

I can really suggest to let this job be done by some kind of 
cross-compile environment such as buildroot 
(http://buildroot.uclibc.org) or OpenEmbedded unless you have very good 
reasons to do it yourself.


More information about the Alsa-devel mailing list