[alsa-devel] [PATCH] Per Application Volume Control plugin for ALSA

James Huk huk256 at gmail.com
Mon Oct 18 23:21:13 CEST 2010

@Colin Guthrie:

> As a PA hacker, I'd be interested to know what apps were causing you
> problems when you used PA so that we could help make them better for
> other users who do want to use PA. If you could provide any details or
> debug info, that would be great.

Well let me name a few:

-Quake4 - sound worked, but some latency was growing with time - after
about 30-60 minutes game restart was required because sound latency
was around 1000 ms
-SDL based apps (zsnes is the one I use a lot) - sound was lower
quality with PA, than with clean ALSA or OSS4, even with
SDL_AUDIODRIVER=pulse (but in that case - this may be zsnes fault as
-wine - even with PA patch, I got poor latency in some apps, and more
crashes than with clean ALSA/OSS4
-KEGA Fusion (Megadrive emulator = freeware but closed-source) - well,
this is a special case - PA acted pretty weird with this one. It
started OK - I used PA in debug mode so I could see something like:
"Fusion requested latency of 32 ms - settings minimum latency to 32 ms
- or something similar), so far so good. After some time though, PA
informed me about underruns and started to increase latency to 64,
128...and so on, which caused the emulator to crash (or rather
freeze). Now the weird part is - if I restarted the emulator without
restarting PA, it would set the latency back to the one that crashed
the emu in the first place, and not for the 32 ms it started with -
this of course caused emulator to freeze again. Restarting PA helped
for this(I mean PA would set minimum latency for 32 ms again) but
after few minutes - freeze again (with the same latency problem).

I don't know if this is a bug or a feature of PA, but it caused
troubles for this app (and probably others as well). I did noticed
that with low-latency kernel it was much more difficult to trigger
this bug, I also tried with RT kernel and was never able to trigger it
there either - even when system was on full load, but I didn't test RT
kernel for very long so...

>> Sorry for my English.
>No need to apologise for that, I think it was fine :)

Thanks - English is not my native language, so there probably are some
grammar errors in my posts - that's why I prefer to apologize up front

More information about the Alsa-devel mailing list