[alsa-devel] Mic + Headphone Problem in Samsung R540

Volkan YAZICI yazicivo at ttmail.com
Mon Oct 11 21:16:35 CEST 2010

On Mon, 11 Oct 2010, Valentine Sinitsyn <valentine.sinitsyn at gmail.com> writes:
> 1. Reload soundcard driver with no model specified (i.e. delete "model=basic"
> from modprobe.conf and reboot or do rmmod snd-hda-intel/modprobe snd-hda-intel
> model=auto). This will reset all mixers, so you'll need to enable Capture again
> in order for mic to work.
> 2. If headphones work, you are done.

Despite I tried this setting at least 4 times, this time it worked in
the first try. Maybe I should quit PhD while I am the start of it.

> 3. If not, run HDA Analyzer, find "PIN 0x21" in the left sidebar. Look at
> "Output Amplifier" checkbox group and clear mute checkboxes. Then, switch to
> "AUD_MIX (0x0C)" in the same sidebar and adjust output volume (the same checkbox
> group). You should hear sound in your headphones.
> 4. If not, look at PIN 0x1a and do the same as at step 3.
> 5. If this doesn't help, file a bug report.

Thanks so much Raymond and Valentine for your helpful support. I am in
dept to you.


More information about the Alsa-devel mailing list