[alsa-devel] [PATCHv4 17/18] ASoC: Samsung: Generalize Kconfig symbols
broonie at opensource.wolfsonmicro.com
Tue Nov 23 15:12:56 CET 2010
On Mon, Nov 22, 2010 at 03:37:22PM +0900, Jassi Brar wrote:
> SND_SOC_SMDK_SPDIF -> ASOC_SAMSUNG_SMDK_SPDIF
> SND_SOC_SMDK_WM8580 -> ASOC_SAMSUNG_SMDK_WM8580
> SND_SOC_SMDK_WM9713 -> ASOC_SAMSUNG_SMDK_WM9713
> SND_SOC_GONI_AQUILA_WM8994 -> ASOC_GONI_AQUILA_WM8994
Hrm. These ones I'm not entirely happy about - we're pretty
consistently using SND_SOC_ rather than ASOC_ throughout the subsystem
so changing to ASOC_ feels like churn. Is there any great reason for
the rename? I don't mind the addition of SAMSUNG_ one way or the other,
it's just the subsystem prefix.
I've applied this just now as the rename patch depends on it.
More information about the Alsa-devel