[alsa-devel] alsa-driver-1.0.23 fails to build on ppc

Elimar Riesebieter riesebie at lxtec.de
Sat May 29 12:16:37 CEST 2010


preparing alsa-driver-1.0.23 for Debian upload I found while building modules all:

  LD [M]  /usr/src/modass/usr_src/modules/alsa-driver/aoa/core/snd-aoa.o
  CC [M]  /usr/src/modass/usr_src/modules/alsa-driver/aoa/fabrics/layout.o
In file included from /usr/src/modass/usr_src/modules/alsa-driver/aoa/fabrics/layout.c:2:
/usr/src/modass/usr_src/modules/alsa-driver/aoa/fabrics/../../alsa-kernel/aoa/fabrics/layout.c: In function 'check_codec':
/usr/src/modass/usr_src/modules/alsa-driver/aoa/fabrics/../../alsa-kernel/aoa/fabrics/layout.c:772: error: 'struct device_node' has no member named 'phandle'
make[8]: *** [/usr/src/modass/usr_src/modules/alsa-driver/aoa/fabrics/layout.o] Error 1
make[7]: *** [/usr/src/modass/usr_src/modules/alsa-driver/aoa/fabrics] Error 2
make[6]: *** [/usr/src/modass/usr_src/modules/alsa-driver/aoa] Error 2
make[5]: *** [_module_/usr/src/modass/usr_src/modules/alsa-driver] Error 2
make[4]: *** [sub-make] Error 2
make[3]: *** [all] Error 2

I found no fix in git. I would be glad if someone could give me a hint.


  Ersatz des Zufalls durch den Irrtum.

More information about the Alsa-devel mailing list