[alsa-devel] [PATCH] hda-intel: Add position_fix quirk for ASUS M2V-MX SE.

Paul Menzel paulepanter at users.sourceforge.net
Wed Mar 10 13:14:05 CET 2010

Am Montag, den 22.02.2010, 08:53 +0100 schrieb Takashi Iwai:
> At Mon, 08 Feb 2010 20:42:46 +0100,
> Paul Menzel wrote:
> > 
> > With PulseAudio and an application accessing an input device like `gnome-volume-manager` both have high CPU load as reported in [1].
> > 
> > Loading `snd-hda-intel` with `position_fix=1` fixes this issue. Therefore add a quirk for ASUS M2V-MX SE.
> > 
> > The only downside is, when now exiting for example MPlayer when it is playing an audio file a high pitched sound is outputted by the speaker.
> > 
> > $ lspci -vvnn | grep -A10 Audio
> > 20:01.0 Audio device [0403]: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) [1106:3288] (rev 10)
> > 	Subsystem: ASUSTeK Computer Inc. Device [1043:8290]
> > 	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
> > 	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
> > 	Latency: 0, Cache Line Size: 64 bytes
> > 	Interrupt: pin A routed to IRQ 17
> > 	Region 0: Memory at fbffc000 (64-bit, non-prefetchable) [size=16K]
> > 	Capabilities: <access denied>
> > 	Kernel driver in use: HDA Intel
> > 
> > [1] http://sourceforge.net/mailarchive/forum.php?thread_name=1265550675.4642.24.camel%40mattotaupa&forum_name=alsa-user
> > 
> > Signed-off-by: Paul Menzel <paulepanter at users.sourceforge.net>
> Applied.  Thanks.

Unfortunately I have to report that I noticed that with this change
sometimes audio just fails the following way.

I play an audio file with MPlayer and suddenly at the beginning of a new
title instead of the normal audio only tones as played from a guitar are
played. I do not know how to better describe. Anyway quitting MPlayer
stops audio entirely, but starting to play audio files again still gives
the “guitar” sounds. Playing a song with Totem works though afterward
and then MPlayer works also again.

It just happens arbitrarily once a week and I cannot reproduce this.

I do not see anything in the logs, so I do not know if it is a
PulseAudio issue or something else. :(

Regarding ALSA I only see the following in `/var/log/messages`.

        hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

I do not know how to best proceed. Maybe dequeue this patch?



[1] patch alsa-hda-intel-add-position_fix-quirk-for-asus-m2v-mx-se.patch added to 2.6.33-stable tree
[2] patch alsa-hda-intel-add-position_fix-quirk-for-asus-m2v-mx-se.patch added to 2.6.32-stable tree
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20100310/f4f64869/attachment-0001.sig 

More information about the Alsa-devel mailing list