[alsa-devel] [PATCH 2/5] ALSA: usb-audio: unify UAC macros and struct names
daniel at caiaq.de
Wed Jun 16 19:40:44 CEST 2010
On Wed, Jun 16, 2010 at 07:34:49PM +0200, Takashi Iwai wrote:
> At Wed, 16 Jun 2010 17:57:28 +0200,
> Daniel Mack wrote:
> > diff --git a/include/linux/usb/audio.h b/include/linux/usb/audio.h
> > index c51200c..a54b825 100644
> > --- a/include/linux/usb/audio.h
> > +++ b/include/linux/usb/audio.h
> > @@ -39,8 +39,8 @@
> > #define UAC_MIXER_UNIT 0x04
> > #define UAC_SELECTOR_UNIT 0x05
> > #define UAC_FEATURE_UNIT 0x06
> > -#define UAC_PROCESSING_UNIT_V1 0x07
> > -#define UAC_EXTENSION_UNIT_V1 0x08
> > +#define UAC1_PROCESSING_UNIT 0x07
> > +#define UAC1_EXTENSION_UNIT 0x08
> So now we have mixed prefix here, UAC_ and UAC1_.
> Isn't it a bit confusing, too?
> Honestly, I have no much preference about this name-ruling.
> But it's of course better if it's stabilized :)
Well yeah, I hate that too, especially as it is a matter of taste
eventually. However, the idea is: things that are common for both UAC1
and UAC2 are prefixed with UAC_, and only those things that are special
get a number suffix. Which is the case in the block you quoted above.
(This perticular detail is really the greatest unnecessary confusion in
the UAC2 spec, btw. They just drop one enumeration value and shuffled
two others around for no obvious reason. Now we have to live with that.)
More information about the Alsa-devel