[alsa-devel] acer aspire 8943g with alc670

Miroslav Šulc fordfrog at gmail.com
Thu Jul 29 18:24:30 CEST 2010

 Dne 29.7.2010 17:10, Jaroslav Kysela napsal(a):
> On Thu, 29 Jul 2010, Miroslav Šulc wrote:
>> Dne 29.7.2010 15:20, Raymond Yau napsal(a):
>>> 2010/7/29 Miroslav Šulc <fordfrog at gmail.com>
>>>>  hello,
>>>> i'd like to help with making the above soundcard to fully work, but
>>>> have
>>>> no clue what to do exactly. currently the soundcard works pretty
>>>> weird,
>>>> though at least sound goes out :-)
>>>> i tried hda analyzer but did not find any documentation for it so have
>>>> no idea what to do exactly. also, when clicking AUD_IN nodes, i get
>>>> this
>>>> error:
>>>> ** (hda_analyzer.py:10063): WARNING **: column number is a boolean,
>>>> but
>>>> will be interpreted as an integer; this is likely not what you
>>>> intended
>>>> Traceback (most recent call last):
>>>>  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 308, in
>>>> selection_changed_cb
>>>>    self.__refresh()
>>>>  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 276, in __refresh
>>>>    self.load()
>>>>  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 336, in load
>>>>    self.node_window.add(NodeGui(node=n))
>>>>  File "/dev/shm/hda-analyzer/hda_guilib.py", line 86, in __init__
>>>>    self.__build_node(node, doframe)
>>>>  File "/dev/shm/hda-analyzer/hda_guilib.py", line 682, in __build_node
>>>>    vbox.pack_start(self.__build_amps(node), False, False)
>>>>  File "/dev/shm/hda-analyzer/hda_guilib.py", line 365, in __build_amps
>>>>    node.in_amp and node.amp_vals_in or None)
>>>>  File "/dev/shm/hda-analyzer/hda_guilib.py", line 328, in build_caps
>>>>    if ctl.hdactl.amp_index_match(idx):
>>>>  File "/dev/shm/hda-analyzer/hda_proc.py", line 170, in
>>>> amp_index_match
>>>>    count = (self.amp_chs & 1) + ((self.amp_chs >> 1) & 1)
>>>> TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'
> I fixed this issue in the alsa.git repo now.
y, i can confirm the bug is gone, thx :-)
>>>> can anybody pls direct me to some documentation that could help me to
>>>> master hda analyzer and find the way to make the card work correctly?
>>>> miroslav
>>> By using alc670 alsa-info.txt in the alsa bugtracker ,
>> ok, i will post one once i restart my pc as i played with the settings
>> of the driver so i guess the output might be affected.
>>> the latest version
>>> hda_analyzer don't has any error message when clicking AUD_IN node
>> well, in the night i downloaded the app from
>> http://www.alsa-project.org/hda-analyzer.py and have the issue. now also
>> tried alsa git repo and the result is the same, so the bug really is
>> there, at least for me. i can try to debug it in netbeans if i find out
>> how (i do not code in python nor do i use it as coder).
>>> Not sure your error is due to using  /proc instead of text file since I
>>> don't have your codec
>> i tried both, using proc and passing alsa-info.txt file to
>> hda-analyzer.py, both with the same result.
> Put alsa-info.txt somewhere to download or point me to this file in a
> bugreport.
>>> There are error messages when click the "graph" button to generate the
>>> graph.
>>> About the graph
>>> the blue line - connected audio path
>>> the grey line - unconncted audio path
>>> the line turn red when you put the mouse cursor near any line ,
>> so hovering over gray connection makes the connection in the card
>> driver, and hovering over blue connection disables the connection?
> No, you need to edit the node (use open in context menu - right click
> on node).
found that, thx :-)
>                         Jaroslav
> -----
> Jaroslav Kysela <perex at perex.cz>
> Linux Kernel Sound Maintainer
> ALSA Project, Red Hat, Inc.

More information about the Alsa-devel mailing list