[alsa-devel] Regression 2.6.35-rc6: ALSA Intel HDA/Realtek: missing Beep

Mario 'BitKoenig' Holbe Mario.Holbe at TU-Ilmenau.DE
Wed Jul 28 23:27:46 CEST 2010

On Wed, Jul 28, 2010 at 06:03:29PM +0200, Takashi Iwai wrote:
> I wrote:
> > Mario 'BitKoenig' Holbe wrote:
> > > My PC-Speaker Beep control worked in 2.6.34, but is gone in 2.6.35-rc6.
> > It's because now the driver checks the SSID your board sets up.
> > So, it's actually BIOS that clears it.

But the BIOS itself beeps through the sound-card at boot :/

> Or, does the following patch fix?  It's already in sound git tree,

Nope, unfortunately it doesn't. Still no Beep controls, no beep through

May I somehow provide any further data?
Or am I somehow able to tweak it? Is there a module parameter to set
this SSID bit? I mean, it did work before... :)

Thanks for you help & regards
Why did the tachyon cross the road?
Because it was on the other side.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 482 bytes
Desc: Digital signature
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20100728/6cae8dfe/attachment-0001.sig 

More information about the Alsa-devel mailing list