[alsa-devel] [PATCH] Updated alsa-kernel asihpi sources so patches are no longer required.

Eliot Blennerhassett linux at audioscience.com
Mon Jul 5 22:14:54 CEST 2010

Thanks Takashi,

On 05/07/10 21:28, Takashi Iwai wrote:
> At Fri, 02 Jul 2010 11:24:40 +1200,
> linux at audioscience.com wrote:
>> From: Eliot Blennerhassett <eblennerhassett at audioscience.com>
>> Signed-off-by: Eliot Blennerhassett <eblennerhassett at audioscience.com>
> Hrm, really these patches aren't needed?

You are right.  I confused myself:

We are dropping support for older kernels from our internal source, so
now I generate alsa-kernel code directly. (where previously our source
looked like patched alsa-driver version)

These patches should remain in alsa-driver to support older kernels.

> The request_firmware() API is definitely incompatible between 2.4
> and 2.6 kernels, so we'd need a fix anyway in alsa-driver build.


Eliot Blennerhassett
AudioScience Inc.

More information about the Alsa-devel mailing list