[alsa-devel] VGN-P11Z_G (hda-intel ALC262) internal microphone not working

Daniel Chen seven.steps at gmail.com
Thu Jan 14 13:03:20 CET 2010

On Thu, Jan 14, 2010 at 1:52 AM, Takashi Iwai <tiwai at suse.de> wrote:
> Isn't this with the older driver version before disabling the default
> quirk to sony-assamd model?  In the recent version, it would fall
> back to auto model.

Indeed, both of his alsa-info.sh outputs show that he used model=auto
with -driver 1.0.20:
>> working "model=auto":
>> http://www.alsa-project.org/db/?f=67f6a692f0ccd70d6893665d36c8b90a51f4a577
>> also with "power_save=10 power_save_controller=N model=auto":
>> http://www.alsa-project.org/db/?f=618f4d4ae530957b4b6d2b66751871d4073df685

> Having an entry to ALC262_AUTO is fine.  It even reduces a kernel
> message that may wonder user.  So here what we have to check lastly
> is whether VAIO Z21MN (104d:9025) that is currently with toshiba-s06
> works with model=auto or not.  Once after it's confirmed, we can take
> all to auto.

Because I don't have access to 0x104d9025 and I don't wish to
introduce a further regression for that model, I've just respun the
patch against current master HEAD adding his SSID with the model=auto

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-PATCH-v2-ALSA-hda-Use-BIOS-autoprobe-for-another-Son.patch
Type: text/x-patch
Size: 1571 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20100114/45d81561/attachment.patch 

More information about the Alsa-devel mailing list