[alsa-devel] Conexant CX20561 alsa driver not muting headphone jack on Thinkpads when mute button pressed .. any ideas?

Jerone Young jerone.young at canonical.com
Tue Feb 23 10:44:31 CET 2010

So I believe I know the answer (or almost) to the problem. The problem
is the speaker & headphones DACs are not being mixed on the same mixer.

The problem is to figure out which mixer does this I need the spec for
the codec.

Does anyone know I can get a hold of data sheet for the Conexant CX20561
or CXT5051 ?


On Mon, 2010-02-22 at 17:55 -0600, Jerone Young wrote:
> There is an interesting problem with Lenovo Thinkpads X200, X200s, X301,
> & .. looks like W500  using the Conexant CX20561 codec under Linux with
> alsa.
> But if you have your headphone plugged in. You get audio .. but if you
> press the hardware mute button .. it will not mute the headphones. By
> pulling out the headphones you will notice though that the internal
> speakers are muted.
> At first I blamed the bios. But then I did a test under FreeDOS where I
> used the beep command for sound. Sure enough I press the mute button and
> the headphone jack is muted.
> I've been looking for any documentation I can find on the CX20561 but
> there is non out there I can find. I could be wrong, but it seems some
> bit isn't being flipped for this codec to work correctly with this
> functionality with the alsa driver.
> Any ideas?
> I've created a bug here:
> https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4928
> 			Thanks,
> 				Jerone
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

More information about the Alsa-devel mailing list