[alsa-devel] Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG (SB0820)

dbm db.mo at bigpond.com
Sun Feb 21 02:41:32 CET 2010


  Just bought one of these to get around the fact the mobo involved 
wouldn't recognize
any soundcard plugged into either PCI slots (onboard sound disabled in 
BIOS) -- it will
however see a soundcard plugged into the pcie 1x slot.....

03:00.0 PCI bridge: Creative Labs Device 7006 (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=03, secondary=04, subordinate=04, sec-latency=32
        Memory behind bridge: ee000000-ee0fffff
        Capabilities: [50] Power Management version 3
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ 
Queue=0/4 Enable-
        Capabilities: [80] Subsystem: Creative Labs Device 0010
        Capabilities: [90] Express PCI/PCI-X Bridge, MSI 00
        Capabilities: [100] Advanced Error Reporting <?>
        Kernel modules: shpchp

04:00.0 Audio device: Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG
        Subsystem: Creative Labs Device 0018
        Flags: bus master, medium devsel, latency 32, IRQ 16
        Memory at ee000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [dc] Power Management version 3
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Does seemed to be claimed by snd-hda-intel  (vid/pid  1102/0009), but 
subsystem descriptor
of 1102/0018 is seemingly unknown by the drivers. Wild guess here is 
this should be claimed
by ctxfi.ko? I can provide a list of hardware IC's fitted to the card -- 
most of them are *not*
codec chips afaict.....that said, 2 oncard chips I cannot readily 
identify. My suspicion is it's
like other cards covered by  ctxfi.ko in that the card  has no 
ac97-codec  fitted and is just a
plain ole' sblive type card....but this is only speculation...

Anyone seens one of these, or have any idea where to start poking for 
clues (if any) to get it


More information about the Alsa-devel mailing list