[alsa-devel] [PATCH] Sync with AudioScience current CVS at version 4.03.04

Eliot Blennerhassett linux at audioscience.com
Tue Feb 2 21:45:26 CET 2010

Takashi Iwai wrote:
> At Tue, 02 Feb 2010 21:16:11 +1300,
> Eliot Blennerhassett wrote:
>> Greetings,
>> The just submitted patch requires matching firmware
>> http://audioscience.com/internet/download/firmware/dspbins40304.zip
>> As usual, my apologies for the large patch.  Unfortunately it was not
>> possible to split into unrelated subpatches without manually recreating
>> the commit history from our CVS repository.
> Thanks for the patch.  I applied now together with the firmware update.

Thank you.

> I suppose the new firmware is still compatible with the older one?
> I'm asking this because the files are overridden.

In this case, the firmware and driver are a pair that must go together.
I.e. both the driver and the firmware must be updated together.

If the versions do not match, a warning will be logged.

However, now you mention it, I will look at making it a failure if the
major version of driver vs fimware does not match (we changed from 3. to
4. because the message format is incompatible).
I'll follow up with another patch in the next few days.



More information about the Alsa-devel mailing list