[alsa-devel] [RFC] ASoC: multi-component: Add optional kcontrol prefix name for a DAI link
jhnikula at gmail.com
Tue Aug 24 09:23:43 CEST 2010
On Mon, 23 Aug 2010 16:21:45 +0100
Mark Brown <broonie at opensource.wolfsonmicro.com> wrote:
> > +int _snd_soc_dapm_new_controls(struct snd_soc_codec *codec,
> > + const struct snd_soc_dapm_widget *widget,
> > + int num, const char *name_prefix);
> Best not in the header; these are not things individual drivers should
> be worrying their pretty little heads about. If they should be used by
> individual drivers then we need better names than just _.
Yeah, I picked up _ prefix so that name indicates that these functions
are more like for internal use and drivers should use them only
exceptionally. What I'm thinking if we can rid of them completely.
More information about the Alsa-devel