[alsa-devel] intel 8x0 ALSA driver in virtualbox - choppy sound

Lex F archguest at gmail.com
Fri Aug 13 22:54:24 CEST 2010

On 13 August 2010 19:32, Takashi Iwai <tiwai at suse.de> wrote:
> At Fri, 13 Aug 2010 17:37:33 +0100,
> Lex F wrote:
>> Hi
>> Thanks for your reply. I tried to answer your questions below.
>> On 13 August 2010 17:06, Takashi Iwai <tiwai at suse.de> wrote:
>> > We have had many problems with VMware, too :)
>> > Which sound backend are you using?  Direct ALSA / dmix or PA?
>> I believe it's direct ALSA, I have choppy output even with
>> aplay /usr/share/sounds/alsa/*.wav
> It doesn't mean always that you use direct ALSA.  Try to pass -Dplughw
> option to aplay.

It tried that but it did not make any difference. As I already pointed
out to Daniel, I do not have pulse audio installed or any other audio
server for that matter. I run arch and know my installed packages
quite well.

>> I am compiling a kernel with the following options enabled:
>> Would any of these help to determine the cause and suggest a fix?
> Fix VirtualBox :)
> Or try to set xrun_debug and check kernel log as Jaroslav wrote.

I've tried setting xrun_debug to various values as per XRUN DEBUG page
on Alsa Project Wiki yet all I see in my kernel.log is loads of
hwptr_updates and sometimes period_update. I am afraid it does not
mean anything to me. I certainly do not see any obvious errors.

Can somebody please advise what I should be looking for? I can post
the output here.



More information about the Alsa-devel mailing list